SipXCentos5

From SipXtapi

Jump to: navigation, search

CentOS 5 Install Dependencies

 yum install subversion gcc-c++ gdb make pcre pcre-devel alsa-lib-devel autoconf automake pkgconfig libtool valgrind rpm-build yum-utils doxygen

need autoconf 2.6X for mediaLib

 rpm -U autoconf-2.61-8.i386.rpm

Installed epel to get spandsp

 rpm -i epel-release-5-4.noarch.rpm
yum install spandsp spandsp-devel

(this pulls in libtiff as a dependency)

  • Optional stuff

GSM codec dependencies

 yum install gsm-devel

FFmpeg dependencies

 yum install yasm

sox for audio file conversions (e.g. prompts)

yum install sox
Personal tools